Creating and Manipulating Jobs

Incident Report for Buildertrend

Resolved

The issue is confirmed resolved!
Posted Dec 17, 2024 - 15:58 CST

Monitoring

Our fix has been implemented and our testing is showing all issues have been resolved. We will continue to monitor until we are fully confirmed fully functional.
Posted Dec 17, 2024 - 15:36 CST

Identified

We are currently experiencing a degraded user experience with jobsite creation and manipulation. We have identified and are working to resolve the issue for our clients as soon as possible.
Posted Dec 17, 2024 - 15:05 CST
This incident affected: Buildertrend.net.