Inbound email delivery delayed

Incident Report for Buildertrend

Resolved

Our inbound email system is fully operational! All delayed email has been processed.

Thank you for your patience while we resolved this incident!
Posted Sep 17, 2024 - 17:35 CDT

Monitoring

Our fix has been implemented and everything is currently processing correctly. Old messages will continue to appear in their respective areas in the application as the queue is completed.

We'll continue to monitor and close the issue out once we've confirmed all email has been properly processed.
Posted Sep 17, 2024 - 13:49 CDT

Update

Any new messages are processing as expected. We are working on processing older email messages now.
Posted Sep 17, 2024 - 10:36 CDT

Update

Emails remain delayed this morning. We are working to restore normal functionality.
Posted Sep 17, 2024 - 08:36 CDT

Update

Emails continue to be delayed at this time. Our engineers are continuing to work the issue and will update as soon as possible.
Posted Sep 16, 2024 - 23:17 CDT

Update

Our engineering staff is continuing to work on this issue.
Posted Sep 16, 2024 - 22:35 CDT

Update

We are engineering a solution for the issue.
Posted Sep 16, 2024 - 18:58 CDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 16, 2024 - 16:30 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 16, 2024 - 15:34 CDT

Update

We are continuing to investigate. All messages are being retained, but delivery is delayed.
Posted Sep 16, 2024 - 14:06 CDT

Investigating

We are currently investigating this issue.
Posted Sep 16, 2024 - 13:29 CDT
This incident affected: Buildertrend.net.