Issues logging in

Incident Report for Buildertrend

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 09:10 CDT

Update

We are continuing to monitor for any further issues.
Posted Jun 04, 2026 - 08:47 CDT

Update

We are seeing additional issues. Continuing to investigate. The majority of the application is functional.
Posted Jun 04, 2026 - 08:37 CDT

Update

We are continuing to monitor for any further issues.
Posted Jun 04, 2026 - 08:31 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 08:09 CDT

Investigating

We are currently investigating issues preventing customers from logging into our application.
Posted Jun 04, 2026 - 08:07 CDT
This incident affected: Buildertrend.net.