Connection issues to Buildertrend

Incident Report for Buildertrend

Resolved

The application access and latency have returned to normal.
Posted Mar 10, 2026 - 13:16 CDT

Monitoring

We have mitigated the issue and are monitoring to confirm everything is operational.
Posted Mar 10, 2026 - 12:38 CDT

Update

We are continuing to investigate this issue.
Posted Mar 10, 2026 - 12:30 CDT

Update

We are still investigating, but access and latency have improved.
Posted Mar 10, 2026 - 11:54 CDT

Update

The application is starting to stabilize and we're continuing to monitor.
Posted Mar 10, 2026 - 11:39 CDT

Update

We are continuing to triage the issue.
Posted Mar 10, 2026 - 11:24 CDT

Update

The application is functional, but running slow. We are continuing to investigate.
Posted Mar 10, 2026 - 11:13 CDT

Investigating

We are currently having connection issues to the Buildertrend application.
Posted Mar 10, 2026 - 11:05 CDT
This incident affected: Buildertrend.net.