The QuickBooks Online APIs are returning intermittent 503 timeout errors

Incident Report for Buildertrend

Resolved

Confirmed the incident is resolved.
Posted Sep 02, 2026 - 06:15 CDT

Update

We are continuing to monitor for any further issues.
Posted Sep 01, 2026 - 21:00 CDT

Update

We're awaiting resolution from Intuit's response team and will update our status page as we are notified.
Posted Sep 01, 2026 - 20:59 CDT

Monitoring

We are continuing to monitor the ongoing Intuit outage.
Posted Sep 01, 2026 - 19:26 CDT

Update

Intuit Quickbooks is currently unable to process any requests. You may be experiencing issues of spinning or receiving errors when working on jobs currently linked to QBO. Please visit our status page and subscribe to updates as Intuit works to resolve. https://status.buildertrend.net/
Posted Sep 01, 2026 - 16:25 CDT

Update

Investigating

QuickBooks are currently investigating this issue.
Posted Sep 01, 2026 - 15:57 CDT
This incident affected: Quickbooks (Intuit QuickBooks Online Integration).