All of Buildertrend is back up and running correctly!
Posted Jun 12, 2025 - 16:34 CDT
Monitoring
Bringing Buildertrend back online. As the site continues to load, services will gradually be restored. Third-party services may still be impacted by the outage and and are beyond our control.
Posted Jun 12, 2025 - 15:58 CDT
Update
We are continuing to monitor the issue.
Posted Jun 12, 2025 - 14:58 CDT
Update
We have put up our maintenance page to protect user data. It's looking like part of our application is coming up in different regions. Continuing to monitor.
Posted Jun 12, 2025 - 14:21 CDT
Update
We are continuing to monitor.
Posted Jun 12, 2025 - 13:49 CDT
Identified
This appears to be a broader issue with many other companies using our same provider. We're continuing to monitor.
Posted Jun 12, 2025 - 13:33 CDT
Update
Our .com and sister sites are also inaccessible. This appears to be an issue with our hosting provider.
Posted Jun 12, 2025 - 13:16 CDT
Investigating
We are aware of intermittent issues in our Production environment and are investigating.
Posted Jun 12, 2025 - 13:11 CDT
This incident affected: Buildertrend.net and Buildertrend.com.