Video issues

Incident Report for Buildertrend

Resolved

This incident has been resolved.
Posted Aug 13, 2024 - 15:04 CDT

Investigating

We are currently looking into issues uploading and downloading videos in the program.
Posted Aug 13, 2024 - 09:09 CDT
This incident affected: Buildertrend.net.