We are experiencing issues processing logins. Currently investigating.

Incident Report for Buildertrend

Resolved

The application is fully functional. Some lingering notifications are still processing and will be available as they complete. Thank you for your patience and understanding.
Posted Jan 08, 2025 - 10:53 CST

Monitoring

Access has been restored and everything appears to be functioning correctly. We will continue to monitor before resolving this issue.
Posted Jan 08, 2025 - 09:37 CST

Identified

We are starting to see access restored. Continuing to monitor.
Posted Jan 08, 2025 - 09:35 CST

Update

This appears to be an issue with our hosting provider. We will provide more information when available.
Posted Jan 08, 2025 - 09:30 CST

Investigating

We are currently investigating this issue.
Posted Jan 08, 2025 - 09:22 CST
This incident affected: Buildertrend.net.