Degraded performance for users

Incident Report for Buildertrend

Resolved

Everything has returned to normal operations. Thank you for your patience.
Posted Jul 14, 2026 - 15:17 CDT

Monitoring

The application appears to have stabilized and users are able to use the product freely. We're continuing to monitor.
Posted Jul 14, 2026 - 15:06 CDT

Update

We are continuing to investigate.
Posted Jul 14, 2026 - 14:46 CDT

Investigating

Buildertrend is currently experiencing application slowness. We're actively working on the issue.
Posted Jul 14, 2026 - 14:28 CDT
This incident affected: Buildertrend.net.