Intermittent issues logging in

Incident Report for Buildertrend

Resolved

Issues have been resolved by our provider.
Posted Sep 01, 2026 - 11:21 CDT

Monitoring

Services appear to back online. We're continuing to monitor.
Posted Sep 01, 2026 - 10:54 CDT

Investigating

Our service provider is reporting issues impacting our application. We have reported the issue and are tracking on it carefully.

We appreciate you patience and will inform you when service has been restored.
Posted Sep 01, 2026 - 10:42 CDT
This incident affected: Buildertrend.net.