Degraded performance to our users

Incident Report for Buildertrend

Resolved

Everything is running properly. Thank you for your patience!
Posted Jul 16, 2026 - 16:44 CDT

Monitoring

Issue has been resolved and we're monitoring to confirm.
Posted Jul 16, 2026 - 16:29 CDT

Identified

We've identified the issue and are performing a fix now.
Posted Jul 16, 2026 - 16:06 CDT

Update

Issue appears to primarily be affecting financials and mobile logins. Continuing to investigate.
Posted Jul 16, 2026 - 15:52 CDT

Investigating

We have been alerted to slowing moving around our application. Our team is working on the issue now.
Posted Jul 16, 2026 - 15:36 CDT
This incident affected: Buildertrend.net.