Buildertrend.net not connecting for some users
Incident Report for Buildertrend
Resolved
This issue should be resolved for most users. Anyone still not able to access Buildertrend.net should be able to after the remainder of the third parties process their changes.
Posted Apr 30, 2024 - 14:02 CDT
Update
We are waiting for third-parties we work with to finish processing the fix to this issue. Continuing to monitor. Most users should be up and running correctly now.
Posted Apr 30, 2024 - 12:29 CDT
Monitoring
We have implemented a fix for the connection issue and are continuing to monitor the situation.
Posted Apr 30, 2024 - 09:33 CDT
Identified
We have found the source of the issue and are working toward resolving as quickly as possible. Users should gradually be able to connect properly.
Posted Apr 30, 2024 - 08:49 CDT
Investigating
Some users are unable to connect to Buildertrend. We are investigating the issue.
Posted Apr 30, 2024 - 08:31 CDT
This incident affected: Buildertrend.net.