Australian / New Zeeland Customers Unable to Log In

Incident Report for Buildertrend

Resolved

Incident confirmed resolved. Thank you for your patience!
Posted Jul 23, 2025 - 20:59 CDT

Monitoring

We have identified the issue and incorporated a fix. Continuing to monitor to confirm issue is resolved.
Posted Jul 23, 2025 - 20:58 CDT

Investigating

We are currently investigating this issue.
Posted Jul 23, 2025 - 20:52 CDT
This incident affected: Buildertrend.net.